Forum Liberty Basic France

Débutant » Résolu Cherchez l'erreur
Le 02/11/2012 à 22h13

Administrateur

Groupe: Administrateur

Inscrit le: 04/03/2012
Messages: 2083
J'ai un doute sur mon système.
cette procédure de sauvegarde devrait marcher, et ne marche pas.
Si je mets un nom existant, j'ai bien le message: Ecraser ?
Au clic sur "enregistrer" le filedialog se ferme.
Mais je n'ai pas la notice de fin de sauvegarde. Et pas de fichier au dossier.

Code JB :
 
 
   [savemulti]
       confirm "Record this new level ?"; answer$
       if answer$ = "yes" then
          filedialog "Save As...", "level_**.lev", filename$
          if fileExist(DefaultDir$, filename$) then confirm "ECRABOUILLER ?"; reponse$
          if reponse$ = "yes" then
             if filename$ <> "" then
                open filename$ for output as #seq
                for x=1 to 64
                   print #seq, enr$(1,x)
                   print #seq, enr$(2,x)
                next x
                close #seq  '  CLOSE CLOSE CLOSE
                notice "C'est Sauvé !"
                files DefaultDir$, filename$, info$(
               ' LVname$ = left$(info$(1,0),len(info$(1,0))-4)
             end if
          end if
       end if
   wait
 




Edité par Roland Le 03/11/2012 à 00h01
____________________
Roro

   
Débutant » Résolu Cherchez l'erreur  

 |  |

1 Utilisateur en ligne : 0 Administrateur, 0 Modérateur, 0 Membre et 1 Visiteur
Utilisateur en ligne : Aucun membre connecté
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie